野鳥紀トップページへ 野鳥の写真集・総合目次へ 観察野鳥一覧表へ 制作メモのページへ ご案内のページへ 一シギ二タカ三ツグミへ移動 動画集「ビデオカメラと野鳥」のサイトへ移動

Windows10インストールメモ(2019年5月)

要約
Win10の再インストールの顛末です。

新しく480GBのSSDを購入しました。
これまでは、システムドライブ用に、256GBのSSDを使っていました。
この古いSSDから新しい方にドライブ全部を、つまりOSを丸ごとコピーして(クローンです)入れ換えました。
入れ換え後も、認証を含めて、まったく問題なく動きました。

クローン作業では、領域が古いものと同じ状態でコピーされます。ですので、480GBのSSDの後半の部分が大きく余っています。
そこで、各OSの(Win3種です)領域を拡大する為に、新規インストールをすることにしました。

インストール作業の際、勧められるまま、MSアカウントを登録して作業しました。
MSアカウントにしたのは、ライセンス認証が簡単にできるという謳い文句だった為です。
しかしながら、そのせいでしょう、ユーザー名が中途半端な名前になっていました。
登録の際に使ったメールアカウントの一部が切り取られてユーザー名になっています。
これが、どうしても気に入りません。
そこで、再度の(2回目の)新規インストールになりました。
以下、その作業のメモです。

なお、今まで、古い方では、イベントビューアに大量のエラーが出ていました。
新規インストールすることで、多少なり改善するかもとの思いもありました。
結果、まったく変わりません。エラーイベントが増えたようにも感じます。それでも、支障はなさそうですので、見て見ぬふりです。

この作業が落ち着いたとき、Win10の1903のアップデートが来てしまいました。
躊躇もありましたが、すぐにアップデートを実行しました。
特に問題もなく終わりましたが、アップデートでは、やはり落ち着きません。
1903用のUSBを作って、再再度の新規インストールを実施しました。

つまり、1809の新規インストールと1903のインストールを立て続けに実行した時のメモです。


190518
SSDの購入、クローン作業、新旧交換
SSD(CSSD-S6B480CG3VX)と、HDDスタンド(KURO-DACHI/CLONE/U3)を買いました。

OS(Win10、他Win2種です。)を入れているSSD(256GB)、CSSDS6T256NHG6Qが手狭な感じで、大きめの物に入れ換えです。
新しいSSDは480GBです。
そのクローン作業用にHDDスタンドも購入しました。
SSDやメモリなどが、以前に比べると、かなり安くなってます。今がチャンスと思いました。
HDDスタンドは、HDDだけではなく、SSDも差し込んで簡単に使えるということで、購入しました。

以前、HDDからSSDに移行するとき、フリーのツールを使ってソフト的にクローン作業をしました。
これはこれで問題なく移行できました。
今回は、HDDスタンドを使って、いわば機械的に作業してみました。
Winが起動している状態で、その自分自身のドライブをコピーするのには、多少無理があるかもと心配したのです。

ただ、HDDスタンドに乗せるためには、現在の内蔵されているSSDを取り出さないといけません。
これが面倒でした。
このPCは、いわゆる他作パソコンです。部品を選定して、パソコンショップに組み立ててもらいました。
その後、HDDに関しては、何度か自分で入れ換えもしています。

このSSDは、当初、どうやって取り付けてあるのか分かりませんでした。物がモノだけに狭い所に押し込んであるのです。
ようやく、ネジ一本とフック二つで固定されていることに気付きました。
その一本のネジも、組み立ての途中で締めたみたいで、ドライバが直接届きません。

実は、ネジで固定してある事に気づいたのは大成果でした。
暗くて狭い場所です、よく見えないのです。
これは両面テープみたいなもので止めてある、としか思えず、強引に剥がそうと、実行寸前でした。
最近の本体ケースには、SSDを置く場所が作ってあるのですね。

確か、古い方のPCは、自分でSSDに換装しましたが、その時、両面テープを使った記憶があります。
何しろ、昔のPCボックスには、SSDの設置場所は考慮されていませんでした。

さて、内蔵のSSDを外して、新しい方のSSDと双方をHDDスタンドに立てて、クローンを作りました。
簡単に終わりました。時間を測っていませんが、30分はかからなかったと思います。

クローンで作った新しい方を本体にセットしました。
件のネジは、外すのは何とかなりましたが、取り付ける方は全くダメです。
両面テープも考えましたが、将来、迷うといけません、今回は外から見ても分かりやすいように、針金で縛りつけました。
デスクトップです。極端な話、ただ置いておくだけでも、さほど困りません。

起動してみると、いとも簡単に起動しました。
当たり前といえば、その通りですが、各ソフトの設定もそのままです。まったく変わりません。
ライセンス認証も旧来の通り認証されたままです。
SSDが変わったことに気が付いていないのではないかと思います。

古い方、これまでの起動ドライブだったものを、スタンドに刺して、外付けドライブとして繋いでみると、ドライブレターが付いていません。
ですので、エクスプローラからは見えません。
ディスクの管理からだと見えます。ただ、何やら赤い矢印が付いています。
プロパティを見てもエラーではなさそうです。
これは、逆に、元のSSDから起動して、クローン化した新しいSSDを外付けとして見てみた時もまったく同じでした。
クローンです。同じドライブレターにするわけにはいかないので、このような処理になるのでしょうね。

今後の課題は、新しいSSDの後半部分の200GB の空き領域を使うようにする事です。
本来は、全部を比例配分などでクローン化できるとよかったのですが。
それに、古いSSDの使い道も考えないといけません。


190519
Windows10新規インストール(1809)
倍ほどの容量のSSDに、クローン作業で作った配置のままでは後半部分に大量の空きがあります。
そのまま拡張する方法があるのか、よくわかりません。
そこで、新規のインストールに挑戦です。
インストールの途中で自由に配置を換えたり、拡張したりできますので。

まず、後で気づいたこと、
デスクトップのアイコンの大半は、ウェブページへのリンクと、データドライブのフォルダやファイルへのショートカットです。
インストールの必要のないフリーのアプリも、データドライブに置いて使えます。
データドライブのドライブ文字は、元の状態をメモしておいて、インストール後も、同じドライブ文字に戻して使います。
ですので、元のデスクトップフォルダのショートカット類をバックアップしておいて、インストール後に、使えそうなものを新しいデスクトップに戻してしまえば、作業が楽なはずです。
それまで、何を使っていたかのメモ代わりにもなります。
ただ、アクセス権が問題になりそうな気もします。(これは杞憂でした。)

もう一つ、Chromeのブックマークはよくエクスポートしていますが、FFFTPにも同じ機能があります。
これを忘れていて苦労しました。

さて、具体的なインストール作業です。
最初に、MSのページから、新しくインストール用のUSBを作りました。
USBは大きいアップデートがある都度、作っています。1809に変わった時も、直後に作っていました。
その時に作っていたものと比べると、容量が少し大きくなっています。その間の重要な更新などが含まれていることを期待しています。

BIOS(UEFI)に入って、先ほど作ったUSBから起動させます。
USBを差し込んで、BIOSを見ると、起動デバイスの選択肢に、そのUSBが含まれていて、ワンクリックで起動できます。
BIOSを変更したり、保存したりする必要がありません。一回限りの起動です。

昔は、BIOSで起動順位を変更保存して、USBやCDを最優先で起動していました。
そうすると、インストール途中の再起動で、またUSBなどから立ち上がるという面倒な事態も発生していました。

型どおりインストール作業を進めていくと、驚いたことに途中からマイクが使えるようになりました。
USBマイクを取り付けていて、普段は使わないので無効にしていました。
まっさらな状態で起動されるので、使えるものは使えということでしょうか。
使えるといっても、選択肢が、「はい」か「いいえ」の場合ぐらいで、数か所だけでしたけど、ちゃんと認識はしていました。

途中、Win10の領域を決める段取りがあります。
現状では、クローン作業の結果で、Win10が100GB 、Win7が70GB、Win8.1が70GB程度で配置してあり、その後ろに200GBほどの空きがあります。
Win10のインストールの際、連続したWin7の領域だけ削除してWin10に合併したら、170GBの領域になります。
そうすると、Win8.1は残るはずです。後で、削除したWin7だけを追加すればいい、という魂胆でした。

ただ、この結果は、このWin10のインストール完了後、残っているはずのWin8.1は起動できませんでした。
マルチブートのメニューが出ません。
この合併作業の際に、OEMとかEFIとかの表示のある小さな区画があり、それを削除しました。これが悪かったのかもしれません。
(この件、別記あり)
そこで、すんなりあきらめて、Win8.1の領域も開放し、Win10の領域を拡張する方法で、当初の目的の200GBをWin10に確保しました。
残りの区画を改めて、Win7とWin8.1用にそれぞれ100GB確保しました。
この二つは、Win10が落ち着いてからのインストールですが、ボリュームラベルだけ付けた領域を作っておきます。
これで、次のインストールの際、分かりやすくなります。

この後、細かいこともいろいろありましたが、インストールでMSアカウントを使ったせいで、ユーザー名が変になっていました。
これが気に食わなくて、もう一回、最初からインストールをやり直すことにしました。

調べると、ユーザー名(ユーザーホルダ名)は、追加はできるが変更はできないとの事でした。
この一回目の新規インストールに関しては、このくらいにして、2回目のインストール作業の経過に移ります。



190526
Win10再インストール(1809)
Win10をインストールし直しました。今回は2回目のインストールです。

ここまでの経過です。
新しいSSD(480GB)を購入し、
それまでのシステムドライブのSSD(256GB)を新しいSSDにコピー(クローン)して、入れ替え、
各OSの領域が古いものと同じ状態だったので、領域を拡大する目的で、新規にインストールしました。
そのインストールの際、勧められるまま、MSアカウントを登録して作業しました。
MSアカウントにしたのは、ライセンス認証が簡単にできるという歌い文句だった事もあります。
しかしながら、そのせいでしょう、メールアカウントの一部を切り取ってユーザー名に使われていました。
これが、どうしても気に入りませんでした。
調べたところ、ユーザー名(ユーザーホルダ名)は、追加はできるが変更はできないとの事でした。

そういうことで、今回のインストールでは、ローカルアカウントで乗り切りました。
結果、希望通り、ローカルアカウント名がユーザー名になっていました。(後で調べたら、文字数に制限がありそうです。)
連続してのインストールです。ライセンスは認証されていた状態での作業でした。
直後に確認してみると、既に認証されていました。勿論、紐はついていませんでしたが。
紐は必要だと思います。そのうち、MSアカウントでログインしなおせばいいのでしょう。

インストール直後、何も対策していなくても、デバイスマネージャではエラーは出ていません。
ですが、今回、気になっていたASUSのMBのドライバ類を、あえてインストールしてみました。
結果、変化はありませんでした。

準備しておいた他のドライバも、いくつか試してみました。LANはインストールできませんでした。途中で拒否されました。
オーディオドライバはインストールできました。
結果、何やらデジタルドライバが出現していました。これは、使う方法が分かりません。そういうことかとアンインストールしました。

一時、スピーカの電源が落ちなくなりました。電源OFFでも、USBの電源が残っているようです。
電源の管理をいじっているうちに、正常になりました。
後で考えると、デバイスマネージャーに電源の管理があります。そこを見ればよかったのかもしれません。

なぜか、全部のドライブの書き込みキャッシュが有効になっています。全部、無効にしました。

デスクトップアイコン
コントロールパネル、PC、コンピュータの管理、などのシステム関連のアイコンを出すのに苦労しました。
設定にありました。設定、個人用設定、テーマ、デスクトップアイコンの設定、です。
一番必要なアイコンは、コンピュータの管理、です。これは、コントロールパネルの管理ツールなどにあります。そこから、ショートカットを作ります。これを作っておけば、デスクの管理やデバイスマネージャを簡単に起動できます。

自動再生、選択して、メモリカードに対して行う操作を選んでください。
メモリカードを差し込んだ際、毎回、どうするのか聞いてくるようになりました。
これまで、フォルダを開く、にしていました。これでは、ふた手間ほど増えてしまいます。
対応は、コントロールパネルの自動再生です。ここで指定できます。

Windowsの起動音
コントロールパネルのサウンドのサウンドタブにチェックボックスがあります。

Defender
タスクバーのDefenderのアイコンにエラー(みたいなもの)が出ていました。
開いてみると、MSアカウントを要求されています。
無視、をクリックすると、エラーが消えました。

デスクトップのショートカット
前回の経験を踏まえ、再インストール直前のデスクトップフォルダのショートカット類をバックアップしておきました。
そして、再インストール後に、新しいデスクトップに戻しました。
心配した、アクセス権が問題になることはありませんでした。
バックアップしてあるショートカットを、今回のデスクトップにコピーするだけで問題なく使えます。勿論、リンク先があるものだけです。

シャットダウンと再起動のアイコンをデスクトップに作っています。
再起動の場合は、リンク先を、shutdown.exe /r /t 0、としてあります。
これもバックアップから使えました。使える道理です。C:ドライブの配置は変わりませんので。

余談ですが、
バックアップから戻す際、理屈の上では、コピーで処理するのが当然なはずです。
バックアップしてあるショートカットを今回のデスクトップフォルダにコピーする、ということです。
が、ショートカットへのショートカットでも、結果は同じでした。
そのショートカットへのリンクができそうですが、直接、元のファイルやURLへのリンクになっています。

OneDrive
一回目のインストールの直後は起動していませんでした。
以前は、起動直後にタスクバーに常駐していました。
タスクマネージャーのスタートアップで無効になっていました。
有効にすると回復しました。
2回目のインストールではタスクバーにはありましたが、色違いのアイコンで、未使用みたいな感じです。
フォルダの場所をデータドライブに移動してあります。この手続きをしているうちに普通の色に戻りました。

OneDriveにある、古いビデオファイルでしょうか、再生していると、mpeg2のコーディックが必要、とのことで、ダウンロードしました。

RSSのアイコン
IEで、RSSのアイコンを出させるのに苦労しました。
メニューを出して、表示、ツールバーのコマンドバーにありました。
コマンドバーを表示させるといいということです。

WindowsUpdate
新しく作った、インストールUSBを使っての作業です。
期待通り、途中までは更新はないと表示されていました。
作業を進めていく内、インストールしたアプリに、.NET Frameworkが必要なものがあり、ダウンロードしました。
この直後、これに関する重要な更新が発生しました。
また、Office2007をインストールすると、たくさんの更新が発生します。

ホームページビルダー15のインストール
インストールの際、油断していてYahooツールバーがインストールされてしまいました。すぐアンインストールしました。

HPB15のインストールの時、進行状況を示す棒グラフが、まったく動かない時間があります。
最近のインストールでは、これ以外にも、進行状況が動かない事が多いように思います。
古いソフトは、インストーラの仕様が違うのでしょうかね。

1回、あまりにも動きがないので、待ちきれず、中断してしまいました。
気を取り直して2回目、辛抱強く待って、インストールできました。

途中、旧版のCDを要求されるのが面倒な所です。
ただ、これがないと、このようなメモが作れないので、やむをえません。
今回から、懐かしい旧版、HPB7はインストールしていません。こうなると、古い方でもよかったかなと思います。

HPG15 をインストールした直後は、フォントがEdgeのスタイルになっていました。
なるほどと思いながら、Chromeを入れて、これを既定のブラウザにしたら戻りました。
何やら、ブラウザの設定を取り入れているようです。もっともな話です。(別記あり)

ローカルのホームページエリアに変なフォルダが出来ていて心配しました。
どうやら、SSD交換前に、HPB15でCSSの練習をした時の名残のようです。
遅ればせながら、CSSを取り入れたいのです。今後、15を使う理由の一つです。

オプションをチェックし、一部を修正します。
HTMLファイルの拡張子をhtmに
HTMLソースにGENERATORを組み込む、
自動保存、バックアップをしない、です。
GENERATORは自作のプログラムで生成するページには自分の名前を入れるようにしています。
HPBでページを編集するものはHPBと入れさせるのが筋でしょう。

METAか小文字のmetaになってしまいます。
これを入れないと困るものもあります。実害はないのでこのままです。

CS2
CS2をインストールしました。
タスクバーからでないと起動できないので、そのようにセットします。
これとは別に、全くの新規のインストールなので、登録画面が出ます。
これを消すのに苦労しました。
ネットで調べた結果、
ショートカットの右クリックのプロパティで、管理者として実行と、最小化、を指定して、実行します。
タスクバーからの実行ではありません。今指定したショートカットから実行します。
すると、登録画面だけが出てきます。
ここで、登録しないを指定します。
管理者、最小化の設定を元に戻します。
これで、登録画面は出なくなります。
以前、何かの解決方法だった言語の設定は必要ありません。

筆まめ23
プリンタドライバを入れておかないと、通信面などのデザインが崩れています。
入れると、正常に戻ります。
想像するに、既定のドライバではハガキなどの用紙が設定できないせいのようです。

起動時にユーザー登録画面がでます。登録済みのボタンを押せば、出てこなくなります。

イラスト類のインストールに、今回も1時間40分ぐらいかかりました。
進行状況の棒グラフが、作業中、全く動きません。1時間半ぐらいで、棒グラフが急速に動き出します。その後は、10分ぐらいで終了しました。
DVDから、どこかテンポラリーにコピーしておいて、その後実際の場所に展開する、みたいです。
面倒ですが、これをインストールしておかないと、実際の作業時に、いちいちDVDを差し込まないといけません。

ヘルプから最新版を確認すると、このイラスト類のインストールに時間がかかる問題の改善プログラムがありました。
それでも、1時間50分かかるとのこと、SSDだともっと早くなるのかもしれません。残念なことに、これに気付いたのは、全てが終わった後でした。
この件、再再度のインストールで試してみました。2時間かかりました。

FFFTP
FFFTPの設定をエクスポートすることを忘れていて、一回目のインストール後、困りました。
古い設定ファイルが残っていましたので、それを使って補正しました。大半のパスワードが当時と変わっていて苦労しました。
2回目のインストールの時は時は設定を残しておきました。
なお、設定をiniファイルに変更しようとすると、なぜかエラーになります。

EdMaxFree
EdMaxFreeでは、最初の起動時に、アクセス権に関して、警告のダイアログが出ました。(別記あり)

インストールが必要ないので、プログラムはデータドライブに置いています。このアプリに関しては、昔からそうです。
実行ファイルをクリックするか、先のデスクトップアイコンを復活させて起動するだけです。
そういうことなので、警告が出るのは、さもありなんと思います。
許可すると、通常通り動きました。

EdMaxFreeは、機能も十分ではないのでしょうが、こういう使い方ができるので、データのエクスポートの必要がありません。
バックアップは、時々フォルダ全部をコピーしています。
おかげで、15年前のメールも残っています。
更に、マルチブートの他のOSからも同じものが使えます。使えるはずです。
共有設定をしておけば、他のPCからも使えると思います。

この点、昔試したメモを見つけました。マルチブートのOSからは問題なしです。
共有のPCからは、読み書きを許可しないといけませんが、動きます。
しかし、変則的な方法で使い込んでいくと、どのような弊害が出るのかわかりませんので、緊急の場合の覚えです。

ここまで、EdMaxFreeとHSP関係以外は、インストールの必要ないアプリでも、システムドライブに、まとめてフォルダを作って配置していました。
この間の作業で、全部、データドライブに配置してもいいのではないかと思い至った次第です。
念の為もあり、再インストール後もドライブ文字を同じにしています。

Office2007
Word2007で起動時、終了時に警告が出ます。
「実行しようとしている機能には、マクロまたはマクロ言語のサポートを必要とするコンテンツが含まれています、云々」
調べてみると、コントロールパネルのプログラムと機能からOfficeに機能を追加するといい、とありました。
Office2007、変更、共有機能、VisualBasicForApplocationをマイコンピュータから実行です。
確かにこれで解決しました。この作業にOfficeのCDは必要ありませんでした。
インストールの時、インストーラ任せで作業をすると問題にならないのでしょう。
今回は、WordとExcel以外は何もインストールしませんでした。

プリンタドライバ(MG6230)
2015年にダウンロードしたものが現在でも通用します。ファイルサイズが、現在Canonのページにあるものと同じです。
プリンタはWi-Fi接続です。説明では、ケーブルをつなぐなと出ています。
しかしながら、Wi-Fiの場合は、電源を入れてからインストールを始めないと、プリンタがないといわれます。

MP Navigator EX Ver. 5.0.2、はスキャナのユーティリティです。古い写真を取り込むのに重宝しています。
ファイル名は、mpnx_5_0-win-5_0_2-ea23_2・・・となっています。
XPSドライバも入れました。仕上がりがきれいになるような話です。しかし、通常のプリンタには普通のものを指定しています。

AVG
AVGのダイアログがブロックされているようです。
一回目のインストールの時は、普通にダイアログが出ていました。
インストール前、一回目のインストールまでは、HSPで作った自作のアプリを起動した時、初回は必ず警告のダイアログが出ていました。
お待ちください、15秒、というものです。
2回目、入れなおしたら、その、お待ちくださいのダイアログは出ません。しかし、監視はしているようで、アプリが止まります。
しばらくすると、正常に動き出します。理屈がわかっているので驚きはしませんが、困ったものです。
AVGにも修復がありました。試してみましたが変化なしです。

回復ドライブ
回復ドライブを作りました。
説明では、32GBが必要とありましたが、実際には6GBほどの容量です。作業には45分ほどかかりました。
ただ、以前作っていたものより少し増えています。

よくわかっていませんが、
Win10が起動しなくなった場合に、このUSBを使って起動して、作ってある復元ポイントに復元できる、
Win10が起動できる状態なら、直接復元ポイントが使えるので、これは必要ない、ということのようです。

試しに、64GBのUSBに作ってみたら、32GBの領域を作って、そのうちの7GBほどを使っていました。大半余っているということです。この事、昔経験したように思います。

この時の必要な容量は8GBと出ていました。
そこで、何度目かの作成を実施しました。もったいないので、ここまでに作ったものは全部破棄して8GBを差し込みました。
今回はちょうど1時間かかりました。

いずれにしろ、実際に試してみる事はできません、困ったものです。

Windows7のインストール
Win7をインストールしようとして、USBを作りました。UEFIから起動して作業に入りました。
しかし、マウスを認識しません。マウスカーソルが出ません。
タブキーで進行していましたが、途中、何やらドライバがないといわれて先へ進めません。
終了したいのですが、終了の方法がありません。普通なら、窓の右上の赤いバッテンをクリックするだけです。
そのマウスが使えない状態です。
タブキーでフォーカスをバッテンに移動できるときもあるのですが、今回はうまくいきません。
そこで、旧機を立ち上げて調べました。
Alt+F4で、終了ダイアログが出せるとのこと、実際、そうでした。終了確認のダイアログが出て、タブキーで移動できるボタンがあります。
無事、終了できました。

調べてみると、Win7のUSBからのインストールは面倒みたいです。インストール用にはDVDを作るのが無難です。
DVDはWin10で簡単に作れます。isoイメージの右クリックメニューにディスクイメージの書き込みという項目があります。
3GBほどのイメージで、書き込みに5分、多分ベリファイに10分ぐらいでした。

そのDVDからのインストールでも、最初のうちはマウスカーソルが出ませんでしたが、TABキーなどで進行できました。
そのうち、マウスも使えるようになりました。

途中、警告が出ました。
インストールするパーティションが推奨される順序になっていない、そうです。
強行しました。結果、問題はなかったようです。
強いて上げると、マルチブートメニューがテキスト版になっています。

Win8.1をインストールするまで、メトロメニューは出ないようです。
やはり、古い方からインストールするもののようです。

ASUSのMB付属のドライバCDは持っています。
でも、新しいのがいいのかもと思って、ASUSのページから、ドライバをダウンロードしていました。
でも、さほど新しいものはなく、インストールの最中にも警告のダイアログが出ます。
かえって面倒だったのかもしれません。
ドライバを入れた後でも、デバイスマネージャーに2個エラーが残っています。
対策をちょっと調べてみましたが分かりません。支障もなさそうなのでそのままです。

インストール完了後、WindowsUpdateを実施しました。重要な更新が136個出てきました。
その後、更新の確認を数回繰り返す必要はありましたが、インストールの失敗はありませんでした。

Win7では、ウイルス対策では、defenderでは役不足のようです。Microsoft Security Essentialsをインストールしました。

Windows8.1のインストール
こちらも、インストールUSBを作りました。Win7と違い、USBからのインストールで済みました。
やはり、新しくISOファイルとツールをダウンロードして作りました。
以前作ったものより、多少容量が大きくなっています。

作ったUSBを使って、まず、Win10上から、setupを実行してみました。これはすぐ失敗しました。
そこで、UEFIに入り、USBからの起動を指定する方法で起動しました。これでうまくいきました。
途中、Win8という表示が出て心配しましたが、結果は8.1になっていました。

Win7のインストールの最中に出た、領域の使い方が悪い、みたいな警告は出ませんでした。
MSアカウントはスキップしてローカルアカウントで作業できました。

HDDなどの書き込みキャッシュが全部ONになっていました。OFFにしました。
これはWin10でもWin7でも皆同じでした。

この時は、デバイスマネジャーのエラーはありませんでした。
しかし、ASUSからダウンロードしていたので、チップセットとLANドライバを入れておきました。

WindowsUpdateが始まりません。
調べてみると、Win8.1の新規インストールでは、よくある話のようです。

PCのリフレッシュ
このUpdate対策に、リフレッシュを実行してみました。
作業に、インストールの時使ったUSBが必要でした。
作業時間はさほどかかりませんでした。20分前後です。
作業が終わって、最初の再起動では、マルチブートメニューが出ませんでした。
心配しましたが、2度目の再起動で出ました。メトロのままです。

結果、リフレッシュ前と同じです。Updateは進みません。
更新のチェックを始めてから、2時間経過して進みません。そこで諦めました。

ネットを調べたら、KB3138615を直接ダウンロードしてインストールするといい、とありました。
これを実行して、更新の確認を始めたら、1分もたたず69個の更新が出てきました。
かなりの時間を使ってUpdateを済ませました。
更に、再度の確認で、数個のUpdateが出てきました。
これもインストールして終わりでした。その後、何度か再起動して再確認しましたが、完了のようです。

リフレッシュが終わった段階で、デバイスマネージャに3個のエラーが出ていました。
nvidiaも入っていませんでした。
2度目の再起動で見直すと、Nvidiaはインストールされていました。
デバイスマネージャのエラーは1個に減っていました。まだ、Updateは実行していない、確認を始めても何も出てこない段階です。
苦労して、Updateを済ませた段階でも、一つエラーが残っています。

Updateはいつも、重要な更新だけです。
ただ、今回、推奨される更新の中に、ドライバらしきものが一つ、NvidiaのUpdateみたいなものが一つあり、これもインストールしておきました。
それでもデバイスマネージャの残り一つのエラーは消えませんでした。
Nvidiaのコントロールパネルは新しくなったような感じです。

ASUSのMB関連のドライバは準備してあるのですが、特に支障はなさそうなので、そのままです。
Win8.1に関しては、これで良しとします。

デバイスマネージャのエラーは、SMバスコントローラ、とあります。
これを調べると、インテルのチップセットドライバで対応しているようです。
これはASUSのページから準備してあります。インストールしていなかったようです。
インストールしてみると、エラーが消えました。

マルチブートメニューについて
最初にWin10をインストール、
2番目にWin7をインストールしました。
この時点で、マルチブートメニューはテキスト表示です。どちらを優先起動しても変わりません。

3番目にWin8.1をインストールすると、期待通り、メトロ画面になっていました。

各OSに行ったり来たりしているうちに、どのOSを優先起動にするかでメニュー画面が変わることに気づきました。
Win7を優先にするとテキスト、Win10かWin8.1優先だとメトロです。
Win7上で、Win10優先にしてもメトロ画面で立ち上がります。
そういえば、この件、どこかにメモしていたような記憶もあります。

ただし、Win10とWin7、二つのデュアルブートの状態では、どちらを優先してもテキストのままでした。どうやら、Win7を後から入れたせいのようです。
3番目にWin8.1を入れると、メトロが出るようになりました。やはり、古いものから順番に入れるのが正しいようです。



190608
再再度の新規インストール、Windows 10 May 2019 Update 1903
1903が出たので、すぐアップデートしました。この経過は、簡単にPCメモの方に書いています。

これに飽き足らず、新規インストールに踏み切りました。
新規の方がアップデートより多少なり安定するだろうという期待からです。気は心と言います。
新しく1903用のUSBのインストールメディアも作りました。

ただ、ここまでの2回のインストールは何だったのでしょうか。
強いて言えば、今なら、インストールに慣れているので、いいタイミングだという事でしょう。
以下、主に、前回と違う部分だけを書き出します。

今回もローカルアカウントで通しました。
途中聞かれるプライバシー関係を全部拒否してみました。結果は、特に変化は感じられません。
190610、設定のプライバシーを調べてみたら、まだかなりの部分が許可されていました。
そこで、全部をOFFにしてみました。
やりすぎだろうと心配しましたが、様子を見てみます。

また、マルチブートメニューが消えました。
これは、管理者権限のコマンドプロンプトから、Bcdboot D:\Windowsと、Bcdboot E:\Windowsで復活できました。
前回も、これでやればよかったのかもしれません。

いつものことですが、インストール直後は、電源オプションで高速スタートアップがONになっています。
これをOFFにします。

重要な更新で、インストール済みのKB4497935を、何度もダウンロードするように促されます。
試しに、アンインストールもしてみましたが、変わりません。
改めて、更新プログラムのチェックをしたら、消えました。

EdMaxFreeが、今回はバックアップから戻したショートカットでは起動できませんでした。エラーメッセージは覚えていません。
やむを得ず、フォルダを見ようとしたら、解決するかみたいなメッセージが出て、しばらく待つと、フォルダを開けました。
その後はアイコンから起動できるようになりました。
メール文中のURLがIEで開きます。
対策はあるようです。調査中です。

そのほかのデータドライブにあるアプリは問題なく動きました。
XnViewは設定が残っていて助かりました。サムネイルを好みに合わせるのが大変なのです。

HPB15
HTMLファイルの右クリックメニューから起動すると、フォントが変になります。設定と違うものです。
なにやらEdgeがらみのフォントのようです。
最新版へアップデートしたら解決しました。

OneDrive
ローカルアカウントで起動して、Hotmail、OneDriveいずれにもログインしていない時に、OneDriveのファイルが見えていました。
HotmailにログインしてもOneDriveへのログインを求められました。
OneDriveへログインしたら、場所の変更というリンクがあったので、進むと、フォルダをデータドライブへ変更できました。
以前実行した、リンクを外すなどの作業の方が亜流みたいです。
以前から、データドライブに変更してたあって、そこを指定するだけなのです。データは同期されているはずです。
いつものことですが、設定が終わると、ファイルのチェックが始まります。これに結構な時間がかかります。
多分、というのは、何かのタイミングでダウンロードが始まる場合があります。
ことによると、名目だけ合わせてあるのかもしれません。
フォルダのサイズは同じになっています。

Webメール
Gmailにログインしておけば、GoogleSearchConsoleでのログインは必要ありません。
同じく、Hotmaiにログインしておけば、BingWebMasterへのログインは必要なしです。
同じIDを使っていますので、そんなものでしょう。

YouTube
Gmailへログインしている状態で、
YouTubeへ投稿しようとしたり、クリエーターツールを使おうとすると、まずチャンネルを作れと言って来ました。
焦りました。チャンネルはあります。そのチャンネルを開いての事です。YouTubeにもログインしているはずです。
ようやく、アカウントを切り替える、という項目を見つけました。ここに野鳥紀とmozumozuという二つのアカウントがあって、野鳥紀を選ぶと使えるようになりました。
以前、ブランドチャンネルを作って、チャンネル名を野鳥紀に変更した影響のようです。

Facebookにはビジターモードというものがあり、ユーザー以外が自分のページを見たら、どのように見えるか確認できます。
YouTubeでマイチャンネルを表示させると、管理人用の画面になっています。編集用のボタンがあったり、アイコンが表示されなかったりです。
YouTubeでもビジターモードを作ってもらいたい所です。

デュアルディスプレイです。
サブの方は、古いPC用のディスプレイを共用しています。普段は古い方に繋いでいて、必要な時、ケーブルを差し変えることで、デュアルで使えるようにしています。
そういうことで、サブの方は電源を入れていない事が多いのです。
画面がにぎやかになって、もう少し窓を追加したいな、というとき、電源を入れます。
なお、ディスプレイの電源を入れていなくても、ケーブルを繋いでおくだけで、PCでは認識しています。

インストールの時はシングルで作業します。
今回は、作業が一段落した時、もう一つも繋ぎました。
Win10では何もしなくても認識され、メインとサブも意図通りになっています。

シングルで使うことも多いので、注意することは、アプリをサブの方で終了させないことです。
サブ画面で終了すると、次回そのアプリを使うとき、サブ画面で立ち上がります。
両方電源を入れておけば慌てませんけど、後日、使うときなど、シングルで使うことも多いのです。
で、アプリが起動しないな、ということになります。
冷静に、タスクバーを見たら、理由がわかるのですが、慌ててしまうとそうはいきません。

さて、今回、メイン画面で終了したにも関わらず、次回起動の窓がサブ画面に移動してしまって困りました。
インストール直後のWindowsUpdateでの重要な更新の嵐の中で、設定を、つまり、WinUpdateの窓を開いたままで再起動を要求されます。再起動すると、設定がサブ画面で開きます。
ソケットの関係でしょうか、サブのほうが1番になっています。メインで使っている方が2なのです。

Win8.1では、デュアルにしたとき、アイコンが全部サブ画面に移動していました。
サブの方がメイン(プライマリ)になっていました。入れ変えました。

Win7では、デュアルを認識しません。サブのディスプレイに電源が入りません。
190619追記
折角なので、Win7もデュアルにしようとディスプレイドライバを探していたら、なんとWinUpdateの推奨される更新プログラムにありました。
Nvidiaのページには、もっと新しいドライバもありましたが、こちらで十分です。インストールしました。
よく見ると、他に二つ、ドライバらしき更新が準備されています。Other hardware という文字が入っているものです。
インストールしました。
結果、それまで、デバイスマネージャーに残っていた二つのエラーが一つに減りました。

CS2
ファイルの関連付けは初期設定のまま(インストーラの指定通りに)にしました。以前は何も変えない(新しく関連付けしない)にしていたと思います。

筆まめ23
イラスト類のインストール前に調べると、アップデータが二つありました。
一つは単なるバージョンアップです。
もう一つは、例のイラスト類のインストールが遅いことへの対策と書いてあります。それでも1時間半かかるとありました。
二つともインストールしました。
結果、イラストのインストールに2時間かかりました。
1903インストール前には1時間40分で終わりました。どういうことでしょうか。

HSP3.51
今回、思いきって、これもデータドライブに置いてみました。
作ったスクリプトや実行フィルの事ではなく、HSPエディタを含む本体全部です。
Zipファイルが提供されており、インストーラは必要ないということは分かっていましたが、初期設定とか、関連付けとか、リンクファイルへのパスとかの問題があるかと心配して、これまではインストーラ版を使っていました。

起動はします。
コンパイルも普通にできています。
スクリプトファイルを右クリックして出るメニューの、プログラムから開くで、HSPのエディタを指定すると、次回からはダブルクリックでエディタが起動しました。これで関連付けができたということでしょうか。

他には、ツール、オプションの動作タブで、
設定の保存をiniファイルに、
カレントディレクトリは指定なし、にして使っています。

AVG
今回は、インストールしていません。
1903のうたい文句に、セキュリティの強化とあったものですから、Defenderでいいのかもと思った次第です。
それに、前記している、お待ちくださいの行方が分かりませんので。

BunBackup
データドライブに専用のフォルダを作って、インストールの必要ないフリーのツールなどをまとめて置いて使っています。
これをBunBackupを使って、時々、フォルダごと外付けHDDへバックアップしています。
そのフォルダにはBunBackupも入っています。
矛盾が起きなければいいのですが。

今のところ、実行すると、BunBackupのフォルダに必ずログファイルができます。
次回のバックアップの時、これだけが新しいのでバックアップされています。
その作業で、また新しいログファイルができてしまいます。

回復ドライブを作り直しました。
8GBのUSBが必要と出ました。
1時間5分かかりました。

あとは、余っているSSDの利用方法を考えないといけません。


同じ、Win10のインストールに関して、2016年に作ったページがあります。

190616
Microsoftアカウント
(この項、パソコンメモから引用)
Win10(1903)の新規インストールが落ち着いたので、Microsoftアカウントに切り換えてみました。
アップデート前から使っていたものです。
いつもながら、パスワードやPINを入力させられるのが面倒です。
ま、型どおりの手順を踏んで変更できました。
ライセンス認証を調べると、MSアカウントにリンクされたデジタルライセンス云々、と、紐付きになっています。

突然、背景の色が変わりました。
記憶にある色でしたので、見当は付きました。Win8.1でいつも設定している色です。
その時、古い方のPCのWin8.1で同じMSアカウントを使っていました。
そのせいで同期されたようです。同期をオフにして、元に戻しました。
マルチブートで使っているので、現在、どのOSにいるのか分かり易くするのに、背景の色を使っています。
新旧、同じバージョンのWinは同じ色にしています。こうすると、デスクトップの色を見るだけで、というより、いつでも、どのバージョンか分かります。
ところが、その同期がWin8.1にも適用されています。

同期をOFFにして、Win8.1を調べたら、こちらも同期がOFFになっていました。

ユーザー情報から、MSアカウントの管理を見てみると、以前と同じ新旧二つのWin10のPC名がデバイスに登録されています。
つまり、二つのWin10のライセンスを持っていると認められている状態です。
実際に二つのライセンスを持っています。無償アップグレードがあった時、二つのPCを使っていたので、それぞれアップグレードしました。

旧PCは、 現在、もう一つ持っている別のMSアカウントでログインしています。
ただ、以前に、一回だけ、新PCで使っているアカウントでログインした事があります。
MSは、その時の事をしっかり覚えていて、現在も二つリストしている様です。

ただ、現在、旧PCでMSアカウントの管理を調べると、そちらはそちらで、旧PC名一つが登録されています。
そのアカウントにリンクされています。

形式的には、3個のライセンスを持っているような気分です。
ま、実際に3台もPCがあっても持て余すだけですけど。

落ち着いた所で、netplwizを使って、起動時のパスワードの省略をしておきました。



トップページへ